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Nudgis - LMS integration guide

This documentation describes ways to integrate UbiCast-generated content into an LMS,
both generic or by using our open-source building block (Moodle only). Note that Moodle
will be used as an example throughout this documentation, please refer to your LMS
documentation for specifics.

Cette documentation est également disponible en français.
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Prerequisites
In order to make possible the integration of channels and media in your LMS (Learning
Management System), the Nudgis and the LMS must be in the same domain, because
otherwise cookies (considered as Third-party cookies) will be rejected by most browsers,
breaking authentication in the process.

Correct example:
Moodle: my-moodle.example.com
Nudgis: my-nudgis.example.com
Incorrect example:
Moodle: my.example.com
Nudgis: my.nudgis.com

For LTI version 1.3, the Nudgis servers and the LMS servers must be able to contact each
other using their HTTPS URL.
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1. Nudgis LTI overview

1.1. About LTI

LTI is a protocol that allows LMS users to integrate content provided by third-party
web-based tools simply and in a secure manner.

LTI works with dedicated links to access to the content. Each embeddable content is called
a "tool" for LTI.

Nudgis handles the following versions of LTI:
- LTI 1.0 and LTI 1.1: The authentication protocol is based on OAuth1 and all

communications between the LMS and Nudgis transit through the user browser.
These versions are deprecated and should not be used anymore, unless your LMS
only supports it.

- LTI 1.3: The authentication protocol is based on OAuth2 and the communications
between the LMS and Nudgis transit through the user browser and directly
between the servers (meaning that the LMS and the Nudgis servers must be able
to communicate in both ways using HTTPS). This version is recommended for LTI
integration.

NB: It is not possible to use LTI 1.0/1.1 and LTI 1.3 at the same time with Nudgis because
the LTI attributes are not the same between versions.

LTI urls look like this one:
https://your.nudgis/lti/v125395dfecaao1pn1ue/

The most interesting part of LTI is that it supports the notion of user roles; this means that
the LTI tool provider is aware of the rights that the user should be given when he accesses
content.

To sum up, the security is based on the fact that if the user can access the content inside
the LMS (e.g. student is enrolled to class “A”), then any content inside this class “A” should
bemade available to him.

A non comprehensive list of LTI tool providers and consumers is available here:
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http://developers.imsglobal.org/catalog.html

How the security model works:
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1.2. Nudgis initial setup

Nudgis includes an LTI integration since version 4.6, as part of the supported
authentication backends.

The LTI protocol version 1.3 is supported since Nudgis 11.2.0. Previous versions of LTI are
deprecated.

To setup LTI, it is first necessary to (see help below for each step):
1) Enable LTI inside Nudgis.
2) Register the LMS (either with the dynamic registration feature or by filling the
LMS information manually, see help below for both methods).
3) Define roles permissions.

1) Enable LTI inside Nudgis

To access LTI settings, go to the Administration menu:
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Then enter authentication settings:

Enable the LTI service:
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2) Register the LMS

Using the dynamic registration:

If your LMS handles the dynamic registration feature, the setup will be much easier.
To use this feature, you will have to copy and paste the dynamic registration URL into your
LMS.
The URL can be found in Nudgis LTI settings page:
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Or by filling the LMS informationmanually:

Use this method only if your LMS does not support the dynamic registration feature.

Do not forget to click on the save button once all data is filled.
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Attributes mapping

Depending on your LMS, youmay have to change the user attributes mapping. To get the
user attributes sent by your LMS, you can use the test page (see section 1.3. for further
information on the test page).

For most LMS and when using LTI 1.3, you shouldn't have to change the mapping because
the default values are correct.

The default values are:
● Username: email
● Email: email
● First name: given_name
● Last name: family_name

contact@ubicast.eu
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3) Define roles permissions

The role permissions can then be defined finely (note that two default roles are provided:
Learner and Instructor.)

To help understanding which roles the LMS reports and debug the permissions, you may
add the “Test page” link into the LMS, and click on it. This will let you introspect the role
names defined by the LMS.

Important: In the version 11.1.1 and previous versions, the roles transmitted by the LMS
were automatically prefixed with:

● "urn:lti:role:ims/lis/" for the roles not beginning with "urn:lti:" and not containing
"ims/lis/".

● "urn:lti:" for the roles not beginning with "urn:lti:" and containing "ims/lis/".

contact@ubicast.eu
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1.3. LTI test page

The LTI test page allows you to check that the LTI service is correctly configured. It can also
be used to show the data sent by the LMS to Nudgis.

To use the test page, it should be enabled in the LTI settings of Nudgis:

The link to the test page is available in the LTI settings of Nudgis:

Add the test page url as an LTI link into the LMS, and click on it. It will then display the
values transmitted over LTI for debugging.

1.4. TheMediaManager

The page used in Nudgis for the LTI deep linking feature (content selection).

This page allows to access multiple features:
- Creation of a media by uploading a file.
- Creation of a video by recording the user desktop.
- Selection of an existing media.
- Management of activities (polls and questionnaires).
- Moderation of comments of all media the user canmoderate.
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The page is available at this URL: "/manager/". By default, only media for which the user is
the speaker are shown. It is possible to add the "?all" argument to show all accessible
media.

Documentation on the Deep Linking :
https://www.imsglobal.org/spec/lti-dl/latest/https://www.imsglobal.org/specs/lticiv1p0
https://canvas.instructure.com/doc/api/file.content_item.html
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1.5. Learning Analytics

Note: Since version 8.4.0, it is possible to send playback progress as a grade to the LMS,
simply enable the option in the LTI settings page and in the LMS settings.

1.6. Example workflow

1. Recording is triggered on a UbiCast Miris Box with the speaker_email metadata
provided.

2. When capture is stopped, recording is sent automatically to Nudgis.
3. Upon reception, when the media is ready, Nudgis sends out an email to the speaker

containing the LTI link along with (potentially customer-specific) instructions.
4. After integrating the LTI link in the LMS, when the teacher clicks the link he is

automatically recognized as being an editor andmoderator.
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2. LMS setup examples
2.1.Moodle

2.1.1. Generic LTI integration

Note: Our LTI 1.3 integration does not yet support student submissions (but it is planned). If
you need student submissions, use our moodle plugins. Some plugins may provide this
feature until Moodle provides it natively.
Note 2: Moodle does not support self-signed certificates. Please ensure that the certificate for
Nudgis seen by Moodle is valid.

2.1.1.1. Moodle configuration

First you have to declare the Nudgis server into Moodle as an LTI tool provider using the
administration interface.

Go to the page:
https://yourmoodleserver/admin/search.php#linkmodules

Click on the "Manage tools" button of the "External tool" activity module:
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Then copy and paste the Nudgis dynamic registration URL:

Remember that LTI must be enabled in Nudgis and that youmust be logged in Nudgis with
an administrator account to use this URL.
Click on the "Add LTI Advantage" button.

Moodle will open a page on Nudgis which should show a success message.
Click on the "Close" button:
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Nudgis is now registered in Moodle, click on the "Activate" button to be able to use it in
Moodle:

If necessary, you can customize the name of the tool provider by editing its settings.
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2.1.1.2. Adding content

Go to a course in Moodle and turn on the edition mode in the top right corner of the page:

Then add an activity in the course:

Choose "external tool":

Select the preconfigured tool and click on "Select":

Select a content in the window, the content link will appear in the "tool URL":
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Before saving the activity please check that your browser did not autofill the "Consumer
key" and "Shared secret" with your Moodle user/password. These fields must be empty.
Finally, click on "save and display".
The media is then directly viewable inside Moodle (and administrable if the role allows it.
Access to editing and statistics is indicated below by the red circle on the top right of the
video player):
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2.1.2. Moodle Plugins

Note: these plugins rely on LTI 1.1, and will be deprecated in favor of the generic LTI 1.3
integration in the long run, when student submissions using LTI 1.3 will be available.

A demo is available here for the UbiCast Nudgis Moodle :
https://help.ubicast.tv/permalink/v125cf904c4dbtknl3i6/.

You can find the UbiCast Nudgis Moodle on Moodle plugins directory
https://moodle.org/plugins/?q=ubicast

2.1.2.1. Plugins configuration

UbiCast provides an Open-Source Moodle building block, that once deployed onto your
Moodle server, adds a new activity type. You can find this plugin at this address :

https://moodle.org/plugins/mod_ubicast

Then, you will need to provide your LTI credentials (the key and the secret) to add them to
the Ubicast Nudgis plugin settings (Administration > Advanced features > Plugins > Activity
modules > UbiCast Nudgis plugin) :
https://moodle/admin/settings.php?section=modsettingubicast

You will also if needed to enter your LTI credentials in the external LTI connector.
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Note that two additional plugins are available and will be described later; they require the
main mod_ubicast plugin to function:

- Add a button into text editors:https://moodle.org/plugins/atto_ubicast
- Add a custom channel block: https://moodle.org/plugins/block_ubicast

Please note that when using these plugins, no LTI score (grade) will be posted; this is a
technical limitation of the approach that we chose. If you need scores, you must use the
generic LTI integration.

Download ZIP from Moodle plugin repository then add it to Site Administration > Plugins >
Install Plugins > Install plugin from ZIP file.

You should get in the plugin overview those three plugins in their category respectively
Activity modules, blocks and Atto HTML editor / Atto plugins :

For the Atto plugins, you should have in Site administration > Plugins > Text Editors > Atto
HTML editor > Atto toolbar settings, this toolbar config :

2.1.2.2. Adding content as resource

Enable edit mode, select “Add activity or resource”, scroll down and select “MediaServer
resource”:

contact@ubicast.eu
https://docs.ubicast.eu/

22

https://moodle.org/plugins/atto_ubicast
https://moodle.org/plugins/block_ubicast
mailto:contact@ubicast.eu
https://docs.ubicast.eu/


Nudgis - LMS integration guide

contact@ubicast.eu
https://docs.ubicast.eu/

23

mailto:contact@ubicast.eu
https://docs.ubicast.eu/


Nudgis - LMS integration guide

After the media selection process, the content is pre-selected:
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And will be accessed by teachers and students using LTI
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2.1.2.3. Adding content into text editors

If the UbiCast Nudgis atto button plugin is installed, a new button is visible:

The same selector will be displayed, albeit with additional size settings:

2.1.2.4. Course block plugin

The UbiCast Nudgis block plugin plugin adds a new block type:
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Once added, the settings allow to set the channel (or media) to show:
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Note that you need to copy-paste the channel ID:

The course will now show all videos from the channel in the course:
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2.2. Blackboard

2.2.1. Blackboard configuration

Please refer to the official Blackboard configuration tutorial:
https://help.blackboard.com/Learn/Administrator/SaaS/Integrations/Learning_Tools_Inte
roperability#addlti13

Step 1: Register the application

To setup the LTI integration in Blackboard, you first have to register your Nudgis portal in
the Blackboard applications.
To do that, go on https://developer.blackboard.com and click on "My applications".
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Then click on "Register a REST or LTI application".
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Fill the information as follows:
(replace the domain with the one of your Nudgis portal and set the value you want in the
application name and description)

Click on "Register application".
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Keep all data from the resulting page aside:
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Step 2: Register the tool

In your Blackboard portal, go to "Administrator Panel" > "LTI Tool Providers" (in
"Integrations" section):

Click on "Register LTI 1.3/Advantage tool":

Put the value of the "Application key" from step 1 in the client id field and click on submit.
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In the resulting page, set "Tool status" as "Approved", check all boxes in "User fields to
send" and set "Allow grade service access" to "Yes".
Keep the value of deployment id, it will be necessary for the Nudgis configuration.

Click on "submit" to validate the new tool.
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In the tools list, click on the arrow next to the name of the added tool and click on
"Manage placements":

Click on the create placement button:
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Add a placement to allow users to select content from Nudgis.
You can choose to activate or not "Allow student access".
You can set any value in "Handle".
In the "Target link URI", you can add "?all" in the URL end in order to show all content to
users and not only the content which belongs to the user.

Step 3: Configure LMS in Nudgis
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In Nudgis, go to "Administration" > "Authentication services" > "LTI" and click on "Register
a new LMS" in the "LMS (Learning Management System) definitions" section.
Fill the information as follows:
The client identifier is the "application id" value from step 1.
The deployment identifier value is get from step 2.
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2.2.2. Adding content

Please refer to the official Blackboard documentation :
https://help.blackboard.com/Learn/Instructor/Ultra/Course_Content/Create_Content/Add
_Content_From_External_Sources

Go to a course in Blackboard and click on the "Content" link in the navigation bar.
Hover the "Build content" button and click on the "Nudgis content" link.

Once the Nudgis content is selected, it will appear in the Blackboard course content.

contact@ubicast.eu
https://docs.ubicast.eu/

38

https://help.blackboard.com/Learn/Instructor/Ultra/Course_Content/Create_Content/Add_Content_From_External_Sources
https://help.blackboard.com/Learn/Instructor/Ultra/Course_Content/Create_Content/Add_Content_From_External_Sources
mailto:contact@ubicast.eu
https://docs.ubicast.eu/


Nudgis - LMS integration guide

contact@ubicast.eu
https://docs.ubicast.eu/

39

mailto:contact@ubicast.eu
https://docs.ubicast.eu/


Nudgis - LMS integration guide

2.3. Brightspace

2.3.1. Brightspace setup

As an administrator, go to "Admin tools" > "Manage Extensibility" > "LTI Advantage".

Click on "Register Tool":

Then copy and paste the Nudgis dynamic registration URL:

Be sure to check the "Configure deployment" box.
Remember that LTI must be enabled in Nudgis and that youmust be logged in Nudgis with
an administrator account to use this URL.
Click on the "Register" button.
A popup will appear and you should see a success message:

contact@ubicast.eu
https://docs.ubicast.eu/

40

mailto:contact@ubicast.eu
https://docs.ubicast.eu/


Nudgis - LMS integration guide

Click on the "Close" button.

The Nudgis tool provider is now registered in Brightspace.
You have to enable it to make it available.
To do that, select the tool and click on the "Enable" button next to the "Register" button.

Now, go to "Admin tools" > "External Learning Tools" > "LTI Advantage".
You should see your Nudgis in the enabled tools providers. If it is not enabled, you have to
enable it like in the previous page.
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If you intend to use the Nudgis feature that moves automatically the content according to
the LTI context, you will have to enable the context fields in the tool provider.
To do that, click on the Nudgis link and check the "Link information" in security settings
then save the changes:

For the tool provider to be available in courses, you will have to allow it in each course you
want.
In the settings of the tool provider, click on "Add Org Units":
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Choose the courses you want:

Then click on "Add" and save the changes of the settings.

2.3.2. Using the test page

If you need to use the test page, you will have to go to a course module where the tool
provider is allowed.
Click on the "Exisiting activities" button and on "External learning tools":
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Click on "Create new LTI link".

Fill the name and the URL and click on "Create and insert":

You will now have an activity in the course that allows you to access the Nudgis test page:
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2.3.3. Adding content

For each allowed course, a button to select or create a media from Nudgis is available in
the "Existing activities".

The name of the link can be changed in the "View links" section of the tool provider
settings of Brightspace.

Once a media is selected, it will appear as a course activity:

And when a user click on it, it opens the content with the permissions granted by the user
role:
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2.3.4. Enable content insertion in text editors

A) From the Brightspace External Learning Tools configuration page of the Nudgis
integration, at the bottom of the page, click on the “View Links” link:

B) Click on “New Link”
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C) Select the “Deep Linking Insert Stuff” type

D) From now on the icon below in any text field will allow to insert content
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2.3.5. Enabling playback grades

The player will report a playback grade when the student leaves the page (1.0 if he
watched the entire video).

A) Make sure that the “Send playback progress as grade” is enabled on Nudgis:

B) Ensure that “Auto Create Grade Items” is enabled in the Brightspace External Learning
Tool setup page

C) Grades will now show up in the Manage Grades page (remember that grades will only
get reported for Learner/Student roles, not admin or teacher)
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